Back to overview
Resolved
Amsterdam network is down
Jul 29, 2026 at 3:51pm UTC
Affected services
Amsterdam Network
Resolved
Jul 29, 2026 at 3:55pm UTC
The network is back online. We will continue to monitor the situation closely.
Affected services
Created
Jul 29, 2026 at 3:51pm UTC
Amsterdam network is currently down. We are escalating the issue to our upstream.
Affected services