Back to overview
Resolved
DDoS Attack
Jul 29, 2026 at 5:33am UTC
Affected services
Singapore Network
Resolved
Jul 29, 2026 at 6:15am UTC
The attack has subsided, and services have returned to normal. We will continue to monitor the situation closely.
Affected services
Created
Jul 29, 2026 at 5:33am UTC
Our Singapore location is currently experiencing carpet bombing DDoS attacks. You may experience degraded network performance while we work to mitigate the attack.
Affected services