Back to overview
Degraded
Email Delivery Disruption
Apr 28, 2026 at 2:25am UTC
Affected services
Control Panel Backend
Resolved
Apr 28, 2026 at 2:55am UTC
The issue has now been resolved by our email API provider.
Affected services
Created
Apr 28, 2026 at 2:25am UTC
We are currently experiencing an issue with our email API provider that is preventing emails from being sent. This has been escalated to the provider. We will share updates as soon as more information becomes available.
Affected services