Back to overview
Downtime

Amsterdam network is down

Jan 28, 2026 at 7:06am UTC
Affected services
Amsterdam Network

Resolved
Jan 28, 2026 at 7:27am UTC

The issue appears to be fully resolved. We will share more details once we receive further information from our upstream provider.

Updated
Jan 28, 2026 at 7:26am UTC

Traffic is recovering. We will follow up with our upstream network provider to get more details on the root cause of the issue.

Created
Jan 28, 2026 at 7:06am UTC

Our upstream network is down.